Standards of professional conduct

All Insolvency Practitioners are required to comply with CARB's Standards of Professional Conduct and, any other relevant rules, regulations, guidance or statement issued by the Board including:

  • Public Practice Regulations: All Insolvency Practitioners, irrespective of where they hold appointments (GB/NI, Ireland) must hold a current Practising Certificate and have appropriate Professional Indemnity Insurance. Insolvency Practitioners in Ireland must also hold an Insolvency Practising Certificate. Insolvency Practitioners must also comply with the client money provisions detailed within these regulations.
  • Continuing Professional Development Regulations: all insolvency practitioners must comply with the Continuing Professional Development Regulations. Insolvency practitioners in GB/NI must also comply with chapter 3 of the Insolvency Licensing Regulations & Guidance.
  • Code of Ethics: The Institute's Code of Ethics Part D is intended to assist all Insolvency Practitioners meet the obligations expected of them by providing professional and ethical guidance. Insolvency Practitioners should be aware that Part D should not be read in isolation from the rest of the Code.
  • Standards of Insolvency Practice (SIPs): The purpose of the SIPs is to promote and maintain high standards by setting out required practice and harmonising the approach of Insolvency Practitioners to particular aspects of insolvency practice. All Insolvency Practitioners in Ireland and GB/NI are required to comply with the SIPs applicable to the relevant jurisdiction.

In addition, Insolvency Licence holders (GB/NI) are required to comply with the following regulations:

  • Insolvency Licensing Regulations & Guidance which applies to persons authorised by CARB to act as Insolvency Practitioners under the Insolvency Act 1986 or the Insolvency (NI) Order 1989 and to persons seeking such authorisation.

Was this article helpful?

Is the website not looking right / working right for you? You might need a browser update. Browser support